Future Netwings Forum - The Tech Community  

Go Back   Future Netwings Forum - The Tech Community > Tech Club > Networking

Reply
 
Thread Tools Display Modes
  #1  
Old 06-27-2009, 11:54 AM
sudipta.p sudipta.p is offline
Moderator
 
Join Date: Apr 2009
Posts: 9
Default Can a router be used as a ISP link load balancer?

It is a common issue for all companies who are having routers terminating ISP links on routers. Is there anybody who can post a solution?
Reply With Quote
  #2  
Old 08-12-2009, 05:17 PM
Kunal's Avatar
Kunal Kunal is offline
Administrator
 
Join Date: Apr 2009
Location: India
Posts: 11
Default

Lets say we have a router that uses a DHCP-configured IP connection to one ISP, and a PPPoE connection over the other ISP connection. The connection types have no particular impact on the configuration unless object-tracking and OER (Optimized Edge Routing) and/or policy-based routing is to be used with a DHCP-***igned Internet connection. In these cases, it can be very difficult to define a next-hop router for policy routing or OER. Anyway a sample config is below:


------------------------
track timer interface 5
!
! Configure timers on route tracking
!
track 123 rtr 1 reachability
delay down 15 up 10
!
track 345 rtr 2 reachability
delay down 15 up 10
!
! Use “ip dhcp client route track [number]”
! to monitor route on DHCP interfaces
! Define ISP-facing interfaces with “ip nat outside”
!
interface FastEthernet0
ip address dhcp
ip dhcp client route track 345
ip nat outside
ip virtual-re***embly
!
interface FastEthernet1
no ip address
pppoe enable
no cdp enable
!
interface FastEthernet2
no cdp enable
!
interface FastEthernet3
no cdp enable
!
interface FastEthernet4
no cdp enable
!
interface FastEthernet5
no cdp enable
!
interface FastEthernet6
no cdp enable
!
interface FastEthernet7
no cdp enable
!
interface FastEthernet8
no cdp enable
!
interface FastEthernet9
no cdp enable
!
! Define LAN-facing interfaces with “ip nat inside”
!
interface Vlan1
description LAN Interface
ip address 192.168.108.1 255.255.255.0
ip nat inside
ip virtual-re***embly
ip tcp adjust-mss 1452
!
! Define ISP-facing interfaces with “ip nat outside”
!
Interface Dialer 0
description PPPoX dialer
ip address negotiated
ip nat outside
ip virtual-re***embly
ip tcp adjust-mss
!
ip route 0.0.0.0 0.0.0.0 dialer 0 track 123
!
! Configure NAT overload (PAT) to use route-maps
!
ip nat inside source route-map fixed-nat
interface Dialer0 overload
ip nat inside source route-map dhcp-nat
interface FastEthernet0 overload
!
! Configure an OER tracking entry
! to monitor the first ISP connection
!
ip sla 1
icmp-echo 172.16.108.1 source-interface Dialer0
timeout 1000
threshold 40
frequency 3
!
! Configure a second OER tracking entry
! to monitor the second ISP connection
!
ip sla 2
icmp-echo 172.16.106.1 source-interface FastEthernet0
timeout 1000
threshold 40
frequency 3
!
! Set the SLA schedule and duration
!
ip sla schedule 1 life forever start-time now
ip sla schedule 2 life forever start-time now
!
! Define ACLs for traffic that
! will be NATed to the ISP connections
!
access-list 110 permit ip 192.168.108.0 0.0.0.255 any
!
! Route-maps ***ociate NAT ACLs with NAT
! outside on the ISP-facing interfaces
!
route-map fixed-nat permit 10
match ip address 110
match interface Dialer0
!
route-map dhcp-nat permit 10
match ip address 110
match interface FastEthernet0
-------------------------

I ***ume you dont mean inbound load balance since we both know that you need BGP Multihoming with Public AS Number. In my opinion its better to use dedicated appliances like F5 or Linkproof for inbound traffic. Our customers are pretty happy with Peplink too.
__________________
Success is not final, Failure is not fatal: It's the courage 2 continue that counts.

Last edited by Kunal; 08-12-2009 at 05:45 PM.
Reply With Quote
  #3  
Old 08-12-2009, 05:21 PM
Kunal's Avatar
Kunal Kunal is offline
Administrator
 
Join Date: Apr 2009
Location: India
Posts: 11
Default

I think I read somewhere that enabling Cisco Express Forwarding (CEF) in some high end routers automatically takes care of load balancing... not sure though.
__________________
Success is not final, Failure is not fatal: It's the courage 2 continue that counts.
Reply With Quote
  #4  
Old 09-11-2009, 05:13 AM
sudipta.p sudipta.p is offline
Moderator
 
Join Date: Apr 2009
Posts: 9
Default

Kunal,

CEF alone will not do the job. Cisco's answer to this issue is Optimized Edge Routing (OER).

Following is the link to know more.

http://www.netcraftsmen.net/resource...icles/443.html

But contrary to other initiatives of cisco, this technology has not gained much mileage because this can not simultaneously support inbound ISP load sharing by its own.

Thanks,

Sudipta
Reply With Quote
  #5  
Old 11-09-2009, 05:56 PM
glenfoxman
Guest
 
Posts: n/a
Default Can a router be used as a ISP link load balancer

If you dont use the Dlink as the router bordering the Internet connection, NAT will result in some systems being unable to access the printer. The Dlink and Linksys should be connected together using switch ports LAN on both. Disable DHCP on the DLink, and configure it with an IP in the Linksyss subnet.
_______________________________________
Website I designed for no fax payday advances company.
Reply With Quote
  #6  
Old 11-10-2009, 09:31 AM
glenfoxman
Guest
 
Posts: n/a
Default Can a router be used as a ISP link load balancer

As long as the router has the WAN port disconnected, the DHCP server off and it is connected to the network via a regular LAN port, with some IP address ***igned to it, it should work fine, I have used the same setup before.
_______________________________________
Website I designed for cash advances loans company.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 08:59 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.